(Linux) Yousician App Crashing

Having difficulties with Yousician? Look here for help. Check the stickies first!

Moderators: distanceremovedradio, R0

(Linux) Yousician App Crashing

Postby casbr0 » Sun Jan 29, 2017 1:55 am

Hello, am new to using this app on Linux, which is the current OS on my laptop. I am using the KXStudio distro, based off of Ubuntu 14.04. As I go to start the application, I go through the launcher and that works fine, starts up the app. As the application is started however, I receive an error message: "Yousician was unable to start its audio system. ..." Which is fine, I figure I will have to adjust the settings as I am using a not-so-standard rig. However, upon hitting Ok (or the x at the top of the screen for that matter) the application proceeds to shut off. The screen just disappears. Sometimes I see the 3 dots flashing for a moment, sometimes not at all, and once or twice I have seen it flash for a few moments, as if loading(!), only to completely shut off again! I hope this is an easy fix and doesn't cause too much trouble, perhaps a setting I've missed somewhere, or some quick set-up issue. I installed all the libraries, required of 14.04, just as the FAQ suggested. All seemed well there. Thank you very much for supporting this OS and any and all help you give me as well!
casbr0
 
Posts: 3
Joined: Sun Jan 29, 2017 1:47 am

Re: (Linux) Yousician App Crashing

Postby BrunoC6 » Thu Feb 02, 2017 12:59 pm

Hi casbr0,

Thanks for the detailed report and my apologies for that.

I have shared this post with our Linux development team and they will be trying to reproduce and fix the issue.

In the meantime, could you confirm if after adjusting the settings you are able to launch the app as intended?
--
Bruno Correia
Customer Support at Yousician

Image
Please check our Help Center pages
BrunoC6
 
Posts: 323
Joined: Fri Nov 20, 2015 2:41 pm

Re: (Linux) Yousician App Crashing

Postby casbr0 » Fri Feb 03, 2017 2:38 am

No, it doesn't seem to launch at all now.
casbr0
 
Posts: 3
Joined: Sun Jan 29, 2017 1:47 am

Re: (Linux) Yousician App Crashing

Postby BrunoC6 » Tue Feb 07, 2017 1:04 pm

@casbr0,

Sorry to hear about that :-(

Do you get any error message when launching Yousician?
Could you walk me through what is currently happening when you try to run the app?
--
Bruno Correia
Customer Support at Yousician

Image
Please check our Help Center pages
BrunoC6
 
Posts: 323
Joined: Fri Nov 20, 2015 2:41 pm

Re: (Linux) Yousician App Crashing

Postby casbr0 » Thu Feb 09, 2017 12:35 am

Well, at first, it was as described above: Go to load it, launcher works correctly, loads up the program, screen says that I need to configure my audio device in settings, I click Ok (or the x at the top right corner) and then the app crashes (or just plain old disappears!) and turns off. No error message.. If there is a command line I can run in Konsole (Terminal) that can monitor for error messages, just let me know, and I'll post the info.

Now, it goes as this: I tried RE-installing the libraries, re-ran all the commands. And now, I run the launcher, everything seems fine, and nothing loads at all.
casbr0
 
Posts: 3
Joined: Sun Jan 29, 2017 1:47 am

Re: (Linux) Yousician App Crashing

Postby csbrwnll » Sun Feb 12, 2017 3:22 am

I have reinstalled Windows.. So as to be able to work in Ableton Live Lite. Hopefully this is no longer an issue due to this.. Thank you.
csbrwnll
 
Posts: 1
Joined: Sun Feb 12, 2017 3:21 am

Re: (Linux) Yousician App Crashing

Postby Vantskruv » Fri Feb 17, 2017 6:24 pm

I have a similar problem as well. Though I'm probably running an unupported Linux distribution:

Debian Testing Kernel 4.9.0-1-AMD64
I also use a nvidia card with driver version 375.26
The GPU is a GTX 570M with 1.5GB VRAM.
Edit: OpenGL version string: 4.5.0 NVIDIA 375.26

I'm not sure which installed packages is necessary to show to troubleshoot this.
I have libc++1 and libc++abi1 version 3.5.2 installed.

The logs do not show anything usual, I've tried uploading them as a ZIP-file, but I'm not sure if they followed the post, so I put them here for view:

out.txt------------------
Found path: /media/sda3/Program/yousician/Yousician Launcher/Yousician.app/Yousician
Mono path[0] = '/media/sda3/Program/yousician/Yousician Launcher/Yousician.app/Yousician_Data/Managed'
Mono path[1] = '/media/sda3/Program/yousician/Yousician Launcher/Yousician.app/Yousician_Data/Mono'
Mono config path = '/media/sda3/Program/yousician/Yousician Launcher/Yousician.app/Yousician_Data/Mono/etc'
displaymanager : xrandr version warning. 1.5
client has 2 screens
displaymanager screen (0)(LVDS-0): 1920 x 1080
Using libudev for joystick management


Importing game controller configs
--------------------------------------------------------------------------------------

launcher-out.txt-----------------------
State 0: Checking connection
State 0: Checking Yousician-launcher version
State 0: Yousician-launcher is up to date. Nothing to do.
State 0: Checking Yousician version
State 0: Yousician is up to date.
State 1: Launching Yousician
------------------------------------------------

version.txt--------------------------
Yousician-launcher_Linux_v0.1-131-g0eb6e4c_B_2017-01-20_1212
-------------------------------------------

The problem is when running the launcher. The launcher window appears showing when checking the version. But then it just closes and application terminates without any error. It just does not start up.
Previous I had some problems when yousician window went very strange, I need to force quite the application. After a couple of reboots I got the application running, but sometimes still with problems, and sometimes not. Now it just will not startup.
Vantskruv
 
Posts: 1
Joined: Fri Feb 17, 2017 6:05 pm


Return to General HELP & SUPPORT
cron